I got this error 'java.lang.ClassNotFoundException: com.hp.hpl.jena.rdf.model.Model' when I run my java web service which implement a jena framework function such as OWL reading function. But it worked as a standalone java application and read the owl file correctly. But when I host it as web service and execute the read method in a .net client or eclipse web service client, it gives this error.

any help would really appreciated.

thx

asked 07 Sep '10, 08:29

arlahiru's gravatar image

arlahiru
112
accept rate: 0%

closed 19 Feb '13, 12:08

Signified's gravatar image

Signified ♦
23.7k1623

I've flagged this for attention as a duplicate

(07 Sep '10, 13:21) Comment Bot Comment%20Bot's gravatar image

to which question? pls provide Question # and I'll close this one...

(14 Dec '10, 02:20) Andrew ♦♦ Andrew's gravatar image

Have you solve your problem?i have the same.

(19 Feb '13, 08:15) Hlias Tsoukalas Hlias%20Tsoukalas's gravatar image

The classpath setup of the web application server is wrong.

(19 Feb '13, 09:39) AndyS ♦ AndyS's gravatar image

The question has been closed for the following reason "Duplicate Question" by Signified 19 Feb '13, 12:08

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "Title")
  • image?![alt text](/path/img.jpg "Title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Tags:

×590
×173

Asked: 07 Sep '10, 08:29

Seen: 866 times

Last updated: 19 Feb '13, 12:09