Hello,

I just ran the apt-get install-virtuoso command and it seemed to have run fine. Then when I ran the virtuoso-t -f command, I got the error that there is no such file as virtuoso.ini which is supposed to happen after install.

Is there anything else that I have to do in order to get the virtuoso.ini (their default ini file) created? Or did I miss a step?

Thanks, Alex

asked 23 Mar '11, 19:50

Genadinik's gravatar image

Genadinik
96519
accept rate: 66%


It should get placed in

/etc/virtuoso-opensource-x.x

If its not then, then copy and paste it from the zip/rar download (should be in the /bin/installer directory)

link

answered 23 Mar '11, 22:23

William%20Greenly's gravatar image

William Greenly
5.1k412
accept rate: 13%

Ah yes, the virtuoso.ini file is there in the etc/virtuoso directory. Should I move it to the /usr/local/virtuoso/bin directory from which I run the virtuoso-t -f command? Or what is the correct approach here? - Thanks! :)

(23 Mar '11, 22:42) Genadinik Genadinik's gravatar image

Try running Virtuoso as root, so

sudo virtuoso-t -f

(23 Mar '11, 22:57) William Greenly William%20Greenly's gravatar image

Before you answered I went ahead and just copied the .ini file to the same directory as the virtuoso-f file. And then I ran that file, and it made a bunch of directories and folders in that file. But Virtuoso starts up with errors. Should I revert and put things back? Or am I on somewhat the right track? Thank you!

(23 Mar '11, 23:12) Genadinik Genadinik's gravatar image

Yes you might need to do so or you will get issues with paths

(23 Mar '11, 23:29) William Greenly William%20Greenly's gravatar image

Built Virtuoso 7 from source on Ubuntu 13. The virtuoso.ini file was placed in /usr/local/virtuoso-opensource/var/lib/virtuoso/db/virtuoso.ini. The full command to start it was then:

sudo /usr/local/virtuoso-opensource/bin/virtuoso-t -f -c /usr/local/virtuoso-opensource/var/lib/virtuoso/db/virtuoso.ini

Available at http://localhost:8890, conducter user/pass is dba/dba

link

answered 06 Aug '13, 13:27

bcoughlan's gravatar image

bcoughlan
535
accept rate: 0%

The minimum you need to start virtuoso is the "virtuoso-t" binary and a configuration file "virtuoso.ini". If you can find them post installation use the "find" command to locate them, go to the "virtuoso.ini" file directory run /virtuoso-t -f -c ./virtuoso.ini to start the server in foreground mode to verify it starts successfully. Then Ctrl C and stat in background mode by dropping the "-f" option.

link

answered 25 Mar '11, 02:19

hwilliams's gravatar image

hwilliams
1.2k22
accept rate: 18%

You may find the usage output of virtuoso-t -? helpful...

link

answered 29 Mar '11, 17:29

TallTed's gravatar image

TallTed
2.0k19
accept rate: 14%

I had the same issue. I have not resolved it yet, but I am following hwilliams advice

link

answered 12 Nov '12, 01:57

jomarip's gravatar image

jomarip
111
accept rate: 0%

Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "Title")
  • image?![alt text](/path/img.jpg "Title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Tags:

×191
×180
×10

Asked: 23 Mar '11, 19:50

Seen: 3,626 times

Last updated: 06 Aug '13, 13:27